myITforum and Windows IT Pro Forums

 Config Manager Client Install Fail Error 80070643

Author Message
Bladeseye

  • Total Posts : 1
  • Scores: 0
  • Reward points : 1990
  • Joined: 10/15/2015
  • Status: offline
Config Manager Client Install Fail Error 80070643 Thursday, October 15, 2015 8:49 PM (permalink)
0
Hi Guys,
 
I am new to System Center, and being a Sys Admin in general for that matter, and of course I have been given the job of designing and stading up our entire site as well as all the components we plan on using (most of them).  Lurking on this forum has been a tremendous help thus far but alas I am finally stuck and I am hoping someone here can help me.
 
OK so the problem is I have 2 clients that just absolutely and utterly refuse to install the CM client no matter what method is used.  When I investigate the ccmsetup.log on the client I see that I am being thrown a fatal error from the MicrosoftPolicyPlatformSetup.msi
 
MSI: Action 16:40:14: LoadPolicyPlatformWmiProviders. Loading WMI providers 10/15/2015 4:40:14 PM 700 (0x02BC)
MSI: Action 16:40:14: Rollback. Rolling back action: 10/15/2015 4:40:14 PM 700 (0x02BC)
File C:\Windows\ccmsetup\MicrosoftPolicyPlatformSetup.msi installation failed. Error text: ExitCode: 1603Action: ErrorMessages: 10/15/2015 4:40:22 PM 700 (0x02BC)
InstallFromManifest failed 0x80070643 10/15/2015 4:40:22 PM 700 (0x02BC)
Failed to get client version for sending state messages. Error 0x8004100e 10/15/2015 4:40:22 PM 700 (0x02BC)
Params to send '5.0.8239.1001 Deployment Error 0x80070643. Pre-req: MicrosoftPolicyPlatformSetup.msi. ExitCode: 1603 Action:  ErrorMessages: ' 10/15/2015 4:40:22 PM 700 (0x02BC)
 
So I open up the verbose log that the MSI outputs and am completely overloaded.  After exercising some Google-Fu and doing a ton of reading I find a helpful hint for parsing Verbose logs that points me to this section.
 
-- LoadPolicyPlatformWmiProviders -- Preparing to load provider: PolicyPlatform_LocalStore...
-- LoadPolicyPlatformWmiProviders -- Found namesapce "root\Microsoft\PolicyPlatform\Documents\Local" for provider "PolicyPlatform_LocalStore".
-- LoadPolicyPlatformWmiProviders -- A message was sent to the Installer of INSTALLMESSAGE type: INSTALLMESSAGE_ACTIONDATA.
-- LoadPolicyPlatformWmiProviders -- A message was sent to the Installer of INSTALLMESSAGE type: INSTALLMESSAGE_PROGRESS.
-- LoadPolicyPlatformWmiProviders -- Loading Provider: PolicyPlatform_LocalStore...
-- LoadPolicyPlatformWmiProviders -- Calling MSFT_Providers::Load(ns='root\Microsoft\PolicyPlatform\Documents\Local', providerName='PolicyPlatform_LocalStore')
-- LoadPolicyPlatformWmiProviders -- PolicyPlatform_LocalStore load failed (hr = 0x80041013).
-- LoadPolicyPlatformWmiProviders -- A failure occurred in Lantern::Setup::Utils::SetupUtils::LoadProviders() -- file:enduser\policyplatform\build\setup\customactionutils\setuputils.cpp, line:749, (hr = 0x80041013)
-- LoadPolicyPlatformWmiProviders -- Failed to load WMI providers. (hr = 0x80041013).
MSI (s) (C4!E8) [16:40:14:380]: Closing MSIHANDLE (433) of type 790531 for thread 4072
MSI (s) (C4!E8) [16:40:14:380]: Closing MSIHANDLE (432) of type 790531 for thread 4072
MSI (s) (C4!E8) [16:40:14:380]: Closing MSIHANDLE (434) of type 790531 for thread 4072
-- LoadPolicyPlatformWmiProviders -- A failure occurred in Lantern::Setup::CustomActions::LoadPolicyPlatformWmiProviders() -- file:enduser\policyplatform\build\setup\customactions\customactions.cpp, line:440, (hr = 0x80041013)
MSI (s) (C4:E8) [16:40:14:381]: Closing MSIHANDLE (431) of type 790536 for thread 3324
CustomAction LoadPolicyPlatformWmiProviders returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (s) (C4:FC) [16:40:14:395]: User policy value 'DisableRollback' is 0
MSI (s) (C4:FC) [16:40:14:395]: Machine policy value 'DisableRollback' is 0
Action ended 16:40:14: InstallFinalize. Return value 3.
 
Now not really knowing anything about WMI, except what I have gleamed from studying for my 70-410 and what I have picked up from troubleshooting SCCM, it looks to me like the namespace is resolving properly but the PolicyPlatform_Localstore is not able to load.  From there I started reading up on the WMI repository and it was hinted that there might be something corrupted but that running a wmimgmt /resetrepository was basically a last resort if you could avoid it.  I ran a wmimgmt / verifyrepositroy and have back with everything consistent.  After looking at some other troubleshooting guides I tried re-registering all of the DLL's in the wbem folder as well as the EXE's there (except WMIC and Mofcomp) but alas I saw no change.
 
In one final attempt to understand I looked at some errors thrown in the Event Viewer on the client and noticed I was receiving Event 33 erors in the Application log thrown by something called SidebySide at the same time stamps as the Client install failure.
 
Activation context generation failed for "C:\Program Files\Microsoft Policy Platform\sqlceoledb35.dll". Dependent Assembly Microsoft.VC80.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50608.0" could not be found. Please use sxstrace.exe for detailed diagnosis.
 
I started the sxstrace and ran the installer again and then parse the log but didn't appear to get any new information from it.  I finally attempted to use wbemtest to connect to the "root\Microsoft\PolicyPlatform\Documents\Local" Namespace and try to enumerate the classes because I read that could be a failure point but realized the PolicyPlatform folder contents and that particular namespace only appear to be loaded during the actual install process which goes extremely quickly so I wasn't sure how to check that outside of an install.
 
Now I am baffled and really unsure where to go from here, I don't really understand the ramifications of running a /resetrepository so I wanted to come here and see if anyone had any other ideas first.  I hope I didn't inundate this post with too many useless steps and log files.  After seeing some of the obnoxiously long Log posts on some of the technet forums I tried to keep the snippets short and relevant without leaving anything out.  So who's got some other tests for this newbie to try when I am back at the office.
 
 
#1
    zia.aamir

    • Total Posts : 1
    • Scores: 0
    • Reward points : 340
    • Joined: 12/11/2016
    • Status: offline
    Re:Config Manager Client Install Fail Error 80070643 Monday, December 12, 2016 8:06 PM (permalink)
    0
    Hi, I am having an issue for deploying sccm client through group policy. Some computers are taking the policy and some are not. Those which are not taking, resultant set of policy says, systems needs a reboot but i have rebooted the system and even then there is not effect on those computers. Can someone assist me please.
     
    Thanks
     
     
    #2
      Online Bookmarks Sharing: Share/Bookmark

      Jump to:

      Current active users

      There are 0 members and 1 guests.

      Icon Legend and Permission

      • New Messages
      • No New Messages
      • Hot Topic w/ New Messages
      • Hot Topic w/o New Messages
      • Locked w/ New Messages
      • Locked w/o New Messages
      • Read Message
      • Post New Thread
      • Reply to message
      • Post New Poll
      • Submit Vote
      • Post reward post
      • Delete my own posts
      • Delete my own threads
      • Rate post

      2000-2017 ASPPlayground.NET Forum Version 3.9