myITforum and Windows IT Pro Forums

 "Interactive services detection" pop-up during deployment of Application, install complete

Author Message
jonrowe81

  • Total Posts : 45
  • Scores: 0
  • Reward points : 11000
  • Joined: 7/22/2013
  • Status: offline
"Interactive services detection" pop-up during deployment of Application, install complete Thursday, September 26, 2013 9:01 AM (permalink)
0
I have an MSI one of my techs created in-house that takes two executable software installs and wraps them into one MSI driven installer.  When ran on a computer outside of SCCM, it works perfectly.  When pushed through SCCM, it works...but it does the following:
1) Deploy the software, it installs but in software center it immediately says "past due - will be retried", but low and behold, the program installs correctly.  The first program installs without a problem, we'll call it program A. 
2) When Program B kicks off, an "Interactive Services Detection" window comes up that says "a program running on this computer is trying to display a message" , options are to view the message or ask me later.  If you view the message, it's a blank window...nothing to be seen.  After closing the window, it still shows software as "Past Due - will be retried". If you reboot, refresh inventory cycle/etc...it shows as installed. 
The appenforce.log file shows:
    Advertising MSI package [C:\WINDOWS\ccmcache\n\Epson.msi] to the system. AppEnforce 9/20/2013 1:30:10 PM 4916 (0x1334)
Failed to retreive product information, error code 0x80070643. AppEnforce 9/20/2013 1:30:12 PM 4916 (0x1334)
AdvertisePackage failed (0x80070643). AppEnforce 9/20/2013 1:30:12 PM 4916 (0x1334)
Lowright users might fail to install this application if it requires higher privileges AppEnforce 9/20/2013 1:30:12 PM 4916 (0x1334)
    Executing Command line: "C:\WINDOWS\system32\msiexec.exe" /i "Epson.msi" /q /qn with system context AppEnforce 9/20/2013 1:30:12 PM 4916 (0x1334)
    Working directory C:\WINDOWS\ccmcache\n AppEnforce 9/20/2013 1:30:12 PM 4916 (0x1334)
    Post install behavior is BasedOnExitCode AppEnforce 9/20/2013 1:30:12 PM 4916 (0x1334)
    Waiting for process 3432 to finish.  Timeout = 120 minutes. AppEnforce 9/20/2013 1:30:12 PM 4916 (0x1334)
    Process 3432 terminated with exitcode: 0 AppEnforce 9/20/2013 1:30:17 PM 4916 (0x1334)
    Looking for exit code 0 in exit codes table... AppEnforce 9/20/2013 1:30:17 PM 4916 (0x1334)
    Matched exit code 0 to a Success entry in exit codes table. AppEnforce 9/20/2013 1:30:17 PM 4916 (0x1334)
    Performing detection of app deployment type Epson Document Camera - Windows Installer (*.msi file)(ScopeId_DBF932B9-0653-437A-B7ED-8708C4E752D7/DeploymentType_beca4cbe-ad05-49d8-b0bd-79a861170020, revision 2) for system. AppEnforce 9/20/2013 1:30:17 PM 4916 (0x1334)
+++ Application not discovered. [AppDT Id: ScopeId_DBF932B9-0653-437A-B7ED-8708C4E752D7/DeploymentType_beca4cbe-ad05-49d8-b0bd-79a861170020, Revision: 2] AppEnforce 9/20/2013 1:30:17 PM 4916 (0x1334)
++++++ App enforcement completed (7 seconds) for App DT "Epson Document Camera - Windows Installer (*.msi file)" [ScopeId_DBF932B9-0653-437A-B7ED-8708C4E752D7/DeploymentType_beca4cbe-ad05-49d8-b0bd-79a861170020], Revision: 2, User SID: ] ++++++ AppEnforce 9/20/2013 1:30:17 PM 4916 (0x1334)
 
 
Thoughts?
 
#1
    Riser

    • Total Posts : 273
    • Scores: 10
    • Reward points : 93140
    • Joined: 4/21/2010
    • Status: offline
    Re:"Interactive services detection" pop-up during deployment of Application, install compl Thursday, September 26, 2013 4:32 PM (permalink)
    0
    First, it sounds like there is an issue with the in-house created MSI around Package B.
    Skipping that, check your Detection Method within your Application to verify it is correct. You may want to manually step through and verify the installation and detection method prior to a reboot.
    Another question: Does the install require a reboot? I would think that would revolve around your detection method and why it would show as not installed.
     
    How are you deploying the Application? Required/Available, what options, etc?
     
    #2
      Online Bookmarks Sharing: Share/Bookmark

      Jump to:

      Current active users

      There are 0 members and 2 guests.

      Icon Legend and Permission

      • New Messages
      • No New Messages
      • Hot Topic w/ New Messages
      • Hot Topic w/o New Messages
      • Locked w/ New Messages
      • Locked w/o New Messages
      • Read Message
      • Post New Thread
      • Reply to message
      • Post New Poll
      • Submit Vote
      • Post reward post
      • Delete my own posts
      • Delete my own threads
      • Rate post

      2000-2014 ASPPlayground.NET Forum Version 3.9