myITforum and Windows IT Pro Forums

 SCCM 2012 R2 client push - ccmsetup.exe runs but does not install

Author Message
CyberCafe

  • Total Posts : 3
  • Scores: 0
  • Reward points : 100
  • Joined: 1/22/2014
  • Status: offline
SCCM 2012 R2 client push - ccmsetup.exe runs but does not install Wednesday, January 22, 2014 5:12 AM (permalink)
0

Hi,
 
First post on here and hope you are all well! I have configured a Test SCCM 2012 R2 Server (with SQL 2012) and am trying to push the client to a test machine.The machine runs the ccmsetup.exe when the client is pushed, but it does not install. I have a log here. Im assuming its a permission issue if the process runs but does not install?
 
</ContentLocationRequest>
']LOG]!><time="10:47:33.606+00" date="01-21-2014" component="ccmsetup" context="" type="0" thread="62328" file="siteinfo.cpp:96">
<![LOG[Sending message header '<Msg SchemaVersion="1.1"><ID>{F63053BA-EBC9-429F-B81F-D0350F8D0480}</ID><SourceHost>LCD12018</SourceHost><TargetAddress>mp:[http]MP_LocationManager</TargetAddress><ReplyTo>direct:LCD12018:LS_ReplyLocations</ReplyTo><Priority>3</Priority><Timeout>600</Timeout><ReqVersion>5931</ReqVersion><TargetHost>colsccm-test.lc-uk.org</TargetHost><TargetEndpoint>MP_LocationManager</TargetEndpoint><ReplyMode>Sync</ReplyMode><Protocol>http</Protocol><SentTime>2014-01-21T10:47:33Z</SentTime><Body Type="ByteRange" Offset="0" Length="1070"/><Hooks><Hook3 Name="zlib-compress"/></Hooks><Payload Type="inline"/></Msg>']LOG]!><time="10:47:33.606+00" date="01-21-2014" component="ccmsetup" context="" type="0" thread="62328" file="siteinfo.cpp:177">
<![LOG[CCM_POST 'HTTP://colsccm-test.lc-uk.org/ccm_system/request']LOG]!><time="10:47:33.606+00" date="01-21-2014" component="ccmsetup" context="" type="1" thread="62328" file="httphelper.cpp:807">
<![LOG[Failed to receive ccm message response. Status code = 404]LOG]!><time="10:47:33.624+00" date="01-21-2014" component="ccmsetup" context="" type="2" thread="62328" file="httphelper.cpp:1694">
<![LOG[GetDPLocations failed with error 0x80004005]LOG]!><time="10:47:33.624+00" date="01-21-2014" component="ccmsetup" context="" type="3" thread="62328" file="siteinfo.cpp:532">
<![LOG[Failed to get DP locations as the expected version from MP 'colsccm-test.lc-uk.org'. Error 0x80004005]LOG]!><time="10:47:33.624+00" date="01-21-2014" component="ccmsetup" context="" type="2" thread="62328" file="ccmsetup.cpp:11261">
<![LOG[Sending Fallback Status Point message to 'COLSCCM-TEST.LC-UK.ORG', STATEID='101'.]LOG]!><time="10:47:33.624+00" date="01-21-2014" component="ccmsetup" context="" type="1" thread="62328" file="ccmsetup.cpp:9756">
<![LOG[Failed to get client version for sending messages to FSP. Error 0x8004100e]LOG]!><time="10:47:33.626+00" date="01-21-2014" component="ccmsetup" context="" type="2" thread="62328" file="ccmsetup.cpp:9838">
<![LOG[Params to send FSP message '5.0.7958.1000 Deployment ']LOG]!><time="10:47:33.626+00" date="01-21-2014" component="ccmsetup" context="" type="0" thread="62328" file="ccmsetup.cpp:9887">
<![LOG[State message with TopicType 800 and TopicId {1A39C71C-D2CA-4B09-A235-35FFC6EDBC58} has been sent to the FSP]LOG]!><time="10:47:33.646+00" date="01-21-2014" component="FSPStateMessage" context="" type="1" thread="62328" file="fsputillib.cpp:752">
 
Im pulling my hair out. I can give anymore info if needed.
 
SCCM 2012 R2, SQL 2012 Standard, Windows 7 Enterprise.
 
Hope you can help.





 
#1
    ITSSCCMGUY

    • Total Posts : 8
    • Scores: 0
    • Reward points : 1030
    • Joined: 1/16/2014
    • Status: offline
    Re:SCCM 2012 R2 client push - ccmsetup.exe runs but does not install Wednesday, January 22, 2014 8:12 AM (permalink)
    0
    404 is a "not found" error.  I would check your IIS logs to get more detail in regard to what 404.X error.
     
    Did you set up the System Management container and give the server rights to it?
     
    #2
      CyberCafe

      • Total Posts : 3
      • Scores: 0
      • Reward points : 100
      • Joined: 1/22/2014
      • Status: offline
      Re:SCCM 2012 R2 client push - ccmsetup.exe runs but does not install Wednesday, January 22, 2014 8:20 AM (permalink)
      0
      Hi, thanks for your message. Yes, it looks like the Container was already created when SCCM 2007 was used a few years back and schema extended. The server has full rights to the System, Management Folder. I will look into IIS Logs.
      It looks like permissions as far as I can see?
       
      #3
        ITSSCCMGUY

        • Total Posts : 8
        • Scores: 0
        • Reward points : 1030
        • Joined: 1/16/2014
        • Status: offline
        Re:SCCM 2012 R2 client push - ccmsetup.exe runs but does not install Wednesday, January 22, 2014 8:51 AM (permalink)
        0
        Did you set the Client Installation Account in SCCM and is that user part of the local Administrators group on the workstation?
         
        #4
          CyberCafe

          • Total Posts : 3
          • Scores: 0
          • Reward points : 100
          • Joined: 1/22/2014
          • Status: offline
          Re:SCCM 2012 R2 client push - ccmsetup.exe runs but does not install Wednesday, January 22, 2014 10:57 AM (permalink)
          0
          Hi, it uses the domain admin account on the SCCM Server. On the off chance, I have added the account to the local admin group on the machine, below is the log:
            </ClientLocationInfo>
          </ContentLocationRequest>
          ']LOG]!><time="15:19:49.803+00" date="01-22-2014" component="ccmsetup" context="" type="0" thread="6392" file="siteinfo.cpp:96">
          <![LOG[Sending message header '<Msg SchemaVersion="1.1"><ID>{EC6ECE2E-9856-4592-8043-9244680F0F22}</ID><SourceHost>LCD12013</SourceHost><TargetAddress>mp:[http]MP_LocationManager</TargetAddress><ReplyTo>direct:LCD12013:LS_ReplyLocations</ReplyTo><Priority>3</Priority><Timeout>600</Timeout><ReqVersion>5931</ReqVersion><TargetHost>colsccm-test.lc-uk.org</TargetHost><TargetEndpoint>MP_LocationManager</TargetEndpoint><ReplyMode>Sync</ReplyMode><Protocol>http</Protocol><SentTime>2014-01-22T15:19:49Z</SentTime><Body Type="ByteRange" Offset="0" Length="1070"/><Hooks><Hook3 Name="zlib-compress"/></Hooks><Payload Type="inline"/></Msg>']LOG]!><time="15:19:49.803+00" date="01-22-2014" component="ccmsetup" context="" type="0" thread="6392" file="siteinfo.cpp:177">
          <![LOG[CCM_POST 'HTTP://colsccm-test.lc-uk.org/ccm_system/request']LOG]!><time="15:19:49.803+00" date="01-22-2014" component="ccmsetup" context="" type="1" thread="6392" file="httphelper.cpp:807">
          <![LOG[Failed to receive ccm message response. Status code = 404]LOG]!><time="15:19:49.818+00" date="01-22-2014" component="ccmsetup" context="" type="2" thread="6392" file="httphelper.cpp:1694">
          <![LOG[GetDPLocations failed with error 0x80004005]LOG]!><time="15:19:49.834+00" date="01-22-2014" component="ccmsetup" context="" type="3" thread="6392" file="siteinfo.cpp:532">
          <![LOG[Failed to get DP locations as the expected version from MP 'colsccm-test.lc-uk.org'. Error 0x80004005]LOG]!><time="15:19:49.834+00" date="01-22-2014" component="ccmsetup" context="" type="2" thread="6392" file="ccmsetup.cpp:11261">
          <![LOG[Failed to find DP locations from MP 'colsccm-test.lc-uk.org' with error 0x80004005, status code 404. Check next MP.]LOG]!><time="15:19:49.834+00" date="01-22-2014" component="ccmsetup" context="" type="2" thread="6392" file="ccmsetup.cpp:11117">
          <![LOG[Only one MP colsccm-test.lc-uk.org is specified. Use it.]LOG]!><time="15:19:49.834+00" date="01-22-2014" component="ccmsetup" context="" type="1" thread="6392" file="ccmsetup.cpp:10080">
          <![LOG[Have already tried all MPs. Couldn't find DP locations.]LOG]!><time="15:19:49.834+00" date="01-22-2014" component="ccmsetup" context="" type="3" thread="6392" file="ccmsetup.cpp:11146">
          <![LOG[GET 'HTTP://colsccm-test.lc-uk...M_Client/ccmsetup.cab']LOG]!><time="15:19:49.834+00" date="01-22-2014" component="ccmsetup" context="" type="1" thread="6392" file="httphelper.cpp:807">
          <![LOG[Failed to successfully complete WinHttp request. (StatusCode at WinHttpQueryHeaders: 404)]LOG]!><time="15:19:49.834+00" date="01-22-2014" component="ccmsetup" context="" type="3" thread="6392" file="httphelper.cpp:1013">
          <![LOG[DownloadFileByWinHTTP failed with error 0x80004005]LOG]!><time="15:19:49.834+00" date="01-22-2014" component="ccmsetup" context="" type="3" thread="6392" file="httphelper.cpp:1081">
          <![LOG[Sending Fallback Status Point message to 'COLSCCM-TEST.LC-UK.ORG', STATEID='308'.]LOG]!><time="15:19:49.834+00" date="01-22-2014" component="ccmsetup" context="" type="1" thread="6392" file="ccmsetup.cpp:9756">
          <![LOG[Params to send FSP message '5.0.7958.1000 Deployment Error 0x80004005. Url HTTP://colsccm-test.lc-uk...M_Client/ccmsetup.cab']LOG]!><time="15:19:49.881+00" date="01-22-2014" component="ccmsetup" context="" type="0" thread="6392" file="ccmsetup.cpp:9887">
          <![LOG[State message with TopicType 800 and TopicId {B28DF1BE-280E-470F-9C03-A698A8F79FE6} has been sent to the FSP]LOG]!><time="15:19:49.928+00" date="01-22-2014" component="FSPStateMessage" context="" type="1" thread="6392" file="fsputillib.cpp:752">
          <![LOG['Configuration Manager Client Retry Task' is scheduled to run at 01/22/2014 08:19:49 PM (local) 01/22/2014 08:19:49 PM (UTC) time with arguments ' /ForceInstall /config:MobileClient.tcf /RetryWinTask:1'.]LOG]!><time="15:19:49.928+00" date="01-22-2014" component="ccmsetup" context="" type="1" thread="1224" file="wintask.cpp:315">
          <![LOG[Creating Windows Task Scheduler folder 'Microsoft\Configuration Manager'...]LOG]!><time="15:19:49.928+00" date="01-22-2014" component="ccmsetup" context="" type="0" thread="1224" file="wintask.cpp:160">
          <![LOG[CcmSetup failed with error code 0x80004005]LOG]!><time="15:19:49.928+00" date="01-22-2014" component="ccmsetup" context="" type="1" thread="1224" file="ccmsetup.cpp:10879">
           
           
          #5
            pysclist

            • Total Posts : 11
            • Scores: 0
            • Reward points : 5540
            • Joined: 1/10/2013
            • Status: offline
            Re:SCCM 2012 R2 client push - ccmsetup.exe runs but does not install Thursday, January 23, 2014 2:28 PM (permalink)
            0
            Hi there,

            I am a bit new to 2012 as well & even newer to trying to help others, but it does look like something related to your mp/iis config. From what I've seen, ccm setup will query Ad for MPs, then query the mp for local distribution points to download content from - if it fails looking for DPS , it falls back to an mp which also serve the client files.

            It seems to be failing in talking to the mp

            (Are you doing anything fancy with your client push command line?)

            Being as your site server has been able kick the process of by coping the initial files and starting the ccmexec service on the client, that points to your client push perms being ok.

            Can you see any thing wrong in component monitor in the console for your mp?

            Good trouble shooting :-)

            Colin
             
            #6
              Online Bookmarks Sharing: Share/Bookmark

              Jump to:

              Current active users

              There are 0 members and 3 guests.

              Icon Legend and Permission

              • New Messages
              • No New Messages
              • Hot Topic w/ New Messages
              • Hot Topic w/o New Messages
              • Locked w/ New Messages
              • Locked w/o New Messages
              • Read Message
              • Post New Thread
              • Reply to message
              • Post New Poll
              • Submit Vote
              • Post reward post
              • Delete my own posts
              • Delete my own threads
              • Rate post

              2000-2014 ASPPlayground.NET Forum Version 3.9