myITforum and Windows IT Pro Forums

 Waiting User Condition

Author Message
mhammes

  • Total Posts : 101
  • Scores: 0
  • Reward points : 29170
  • Joined: 4/18/2002
  • Status: offline
Waiting User Condition Wednesday, August 09, 2017 5:12 PM (permalink)
0
I have a package that is set to run with the user is logged off but it never does.  Following is what I see in the execmgr log file, this package worked for most users.
 
 Execution Request for advert DT1200CC package DT10003C program Vista 1.24 Removal state change from WaitingDependency to WaitingEnvironment execmgr 8/1/2017 7:00:00 PM 12056 (0x2F18)
Raising client SDK event for class CCM_Program, instance CCM_Program.PackageID="DT10003C",ProgramID="Vista 1.24 Removal", actionType 1l, value , user NULL, session 4294967295l, level 0l, verbosity 30l execmgr 8/1/2017 7:00:00 PM 12056 (0x2F18)
The user has logged off. execmgr 8/1/2017 9:16:59 PM 4152 (0x1038)
Service startup. execmgr 8/1/2017 9:22:11 PM 4136 (0x1028)
An existing MTC token was not supplied, using ExecutionRequest's Id as MTC token and this execution request is the owner of resultant MTC task. execmgr 8/1/2017 9:22:15 PM 4136 (0x1028)
Request a MTC task for execution request of package DT10003C, program Vista 1.24 Removal with request id: {5BC70CDE-67F8-419B-BB34-8EA28F8A2AAB} execmgr 8/1/2017 9:22:15 PM 4136 (0x1028)
Execution Request for advert DT1200CC package DT10003C program Vista 1.24 Removal state change from WaitingEnvironment to Ready execmgr 8/1/2017 9:22:18 PM 4136 (0x1028)
Raising client SDK event for class CCM_Program, instance CCM_Program.PackageID="DT10003C",ProgramID="Vista 1.24 Removal", actionType 1l, value , user NULL, session 4294967295l, level 0l, verbosity 30l execmgr 8/1/2017 9:22:20 PM 4136 (0x1028)
Execution Request for advert DT1200CC package DT10003C program Install Vista 1.27 and Remove 1.24 state change from WaitingDependency to WaitingDependency execmgr 8/1/2017 9:22:20 PM 4136 (0x1028)
Raising client SDK event for class CCM_Program, instance CCM_Program.PackageID="DT10003C",ProgramID="Install Vista 1.27 and Remove 1.24", actionType 1l, value , user NULL, session 4294967295l, level 0l, verbosity 30l execmgr 8/1/2017 9:22:20 PM 4136 (0x1028)
MTC task with id {5BC70CDE-67F8-419B-BB34-8EA28F8A2AAB}, changed state from 0 to 4 execmgr 8/1/2017 9:22:20 PM 2424 (0x0978)
MTC signaled SWD execution request with program id: Vista 1.24 Removal, package id: DT10003C for execution. execmgr 8/1/2017 9:22:20 PM 2424 (0x0978)
IMaintenanceCoordinator::GetTaskState failed with error code 0x87d00317 execmgr 8/1/2017 9:39:46 PM 2424 (0x0978)
Failed to get MTC task state - 87d00317 execmgr 8/1/2017 9:39:46 PM 2424 (0x0978)
Sending ack to MTC for task with id: {5BC70CDE-67F8-419B-BB34-8EA28F8A2AAB} execmgr 8/1/2017 9:39:46 PM 2424 (0x0978)
IMaintenanceCoordinator::TaskStarting failed with error code 0x87d00319 execmgr 8/1/2017 9:39:46 PM 2424 (0x0978)
Failed to send ACK to Maintanent Task Coordinator, moving this request to READY state. Error code 87d00319 execmgr 8/1/2017 9:39:46 PM 2424 (0x0978)
Package DT10003C, program Vista 1.24 Removal is ready but can not be started because an acknowledgement could not be sent to MTC. execmgr 8/1/2017 9:39:46 PM 2424 (0x0978)
Software Distribution client will wait till it recieves a signal from MTC again. execmgr 8/1/2017 9:39:46 PM 2424 (0x0978)
CServiceWindowEventHandler::Execute - Received SERVICEWINDOWEVENT : START Event execmgr 8/1/2017 10:00:00 PM 3500 (0x0DAC)
CExecutionRequestManager::OnServiceWindowEvent for START execmgr 8/1/2017 10:00:00 PM 3500 (0x0DAC)
Auto Install is set to false. Do Nothing. execmgr 8/1/2017 10:00:00 PM 3500 (0x0DAC)
 
#1
    gjones

    • Total Posts : 2803
    • Scores: 146
    • Reward points : 234480
    • Joined: 6/5/2001
    • Location: Ottawa, Ontario, Canada
    • Status: offline
    Re:Waiting User Condition Thursday, August 10, 2017 8:22 AM (permalink)
    0
    You will have a tough time with run at logoff. Particularly if the user reboot the computer. Why exactly do you want trigger this at logoff?
     
    #2
      mhammes

      • Total Posts : 101
      • Scores: 0
      • Reward points : 29170
      • Joined: 4/18/2002
      • Status: offline
      Re:Waiting User Condition Thursday, August 10, 2017 9:19 AM (permalink)
      0
      I'm not running it at logoff I'm running it only when the user is logged off.  The app has to be closed to upgrade it.
       
      #3
        gjones

        • Total Posts : 2803
        • Scores: 146
        • Reward points : 234480
        • Joined: 6/5/2001
        • Location: Ottawa, Ontario, Canada
        • Status: offline
        Re:Waiting User Condition Thursday, August 10, 2017 9:33 AM (permalink)
        0
        Take a look at the PoSH App deployment toolkit, it will allow you to post message and close applications.
        http://psappdeploytoolkit.com/
         
        #4
          mhammes

          • Total Posts : 101
          • Scores: 0
          • Reward points : 29170
          • Joined: 4/18/2002
          • Status: offline
          Re:Waiting User Condition Thursday, August 10, 2017 10:00 AM (permalink)
          0
          Our deployment is working fine and installing just like it should on most machines.  I just have a handful that are getting this error message.  What does the error message mean?  We have been doing it this way for years with no issues until just recently. Normally it just runs as soon as the user logs off.  There are multiple reasons we don't want to install it when the user is logged on.
           
           
          #5
            gjones

            • Total Posts : 2803
            • Scores: 146
            • Reward points : 234480
            • Joined: 6/5/2001
            • Location: Ottawa, Ontario, Canada
            • Status: offline
            Re:Waiting User Condition Thursday, August 10, 2017 10:05 AM (permalink)
            0
            That is great so what has changed?
            Then why at logon vs when no user is logon?
            I can honestly say I don't know of anyone that use the at logon or logoff truly successfully.
             
             
            #6
              mhammes

              • Total Posts : 101
              • Scores: 0
              • Reward points : 29170
              • Joined: 4/18/2002
              • Status: offline
              Re:Waiting User Condition Thursday, August 10, 2017 11:07 AM (permalink)
              0
              We have been using When no user is logged on for years with no issues.  I wish I knew what changed, nothing that sticks out changed.
               
              #7
                gjones

                • Total Posts : 2803
                • Scores: 146
                • Reward points : 234480
                • Joined: 6/5/2001
                • Location: Ottawa, Ontario, Canada
                • Status: offline
                Re:Waiting User Condition Thursday, August 10, 2017 11:36 AM (permalink)
                0
                At logoff and when no one is logged in are two different things. Exactly which one are you using for this deployment?
                 
                #8
                  mhammes

                  • Total Posts : 101
                  • Scores: 0
                  • Reward points : 29170
                  • Joined: 4/18/2002
                  • Status: offline
                  Re:Waiting User Condition Thursday, August 10, 2017 11:41 AM (permalink)
                  0
                  when no one is logged in
                   
                  #9
                    gjones

                    • Total Posts : 2803
                    • Scores: 146
                    • Reward points : 234480
                    • Joined: 6/5/2001
                    • Location: Ottawa, Ontario, Canada
                    • Status: offline
                    Re:Waiting User Condition Thursday, August 10, 2017 11:57 AM (permalink)
                    0
                    That one works fine, never had any problems with it.
                     
                    #10
                      mhammes

                      • Total Posts : 101
                      • Scores: 0
                      • Reward points : 29170
                      • Joined: 4/18/2002
                      • Status: offline
                      Re:Waiting User Condition Thursday, August 10, 2017 11:59 AM (permalink)
                      0
                      Me either until now. No idea what is causing it.
                       
                      #11
                        Online Bookmarks Sharing: Share/Bookmark

                        Jump to:

                        Current active users

                        There are 0 members and 1 guests.

                        Icon Legend and Permission

                        • New Messages
                        • No New Messages
                        • Hot Topic w/ New Messages
                        • Hot Topic w/o New Messages
                        • Locked w/ New Messages
                        • Locked w/o New Messages
                        • Read Message
                        • Post New Thread
                        • Reply to message
                        • Post New Poll
                        • Submit Vote
                        • Post reward post
                        • Delete my own posts
                        • Delete my own threads
                        • Rate post

                        2000-2017 ASPPlayground.NET Forum Version 3.9